• Postgresql 9.1+
  • Postgresql development packages
  • Python development packages
  • python 2.6 or >= python 3.3 as your default python

If you are using PostgreSQL 9.1, you should use the 0.9.1 release.

If you are using PostgreSQL 9.2 or superior, you should use the 1.0.0 series. (Currently 1.0.1).

If you are using Debian, a packaging effort is ongoing for PostgreSQL 9.4. You can install it from here.

With the pgxn client:

pgxn install multicorn

From pgxn:

unzip multicorn-1.1.1
cd multicorn-1.1.1
make && sudo make install

From source:

git clone git://
cd Multicorn
make && make install